sfGrowl4RailsPlugin - 1.0.0

Provide a helper to use Growl4Rails

You are currently browsing
the website for symfony 1

Visit the Symfony2 website


« Back to the Plugins Home

Signin


Forgot your password?
Create an account

Tools

Stats

advanced search
Information Readme Releases Changelog Contribute
Show source

sfGrowl4RailsPlugin symfony plugin

Port of Jim Fiorato Rails plugin Growl4Rails to Symfony.

Growl4Rails is a javascript component that provides the UI for growl-like notifications in your rails application.

This plugin requires Prototype 1.6 or higher and Scriptaculous 1.7 or higher, use Fabien Potencier sfPrototypePlugin plugin.

Installation

* For symfony 1.0.x
symfony plugin-install http://plugins.symfony-project.com/sfGrowl4RailsPlugin

Usage

Growl4Rails.showGrowl method takes a single hash as an argument. The hash can have the following keys:

image_path - 32x32 icon title - title of the growl message - the growl message

[php]

OR

To handle the 'click' event from the Growl, you can do the following:

Authors

Jim Fiorato -- http://www.writebetterbits.com Original implementation

Alexis Moreno -- http://www.xeux.com.pa Symfony implementation

License

For the full copyright and license information, please view the LICENSE file that was distributed with this source code.